Network connectivity has been restored. ITS will continue to monitor system availability. The issue was linked to our Network provider, Cenic, which provided the following update:
START: 06:43 PDT, Thu 09/17/2026
END: 08:21 PDT, Thu 09/17/2026
SCOPE: Backbone Circuit Down
STATUS: Resolved
COMMENTS:
The outage between the backbone router and switch was resolved by resetting the optic for the affected link. Services have been restored, and no further impact is expected. This incident is considered resolved.
Resolved
Network connectivity has been restored. ITS will continue to monitor system availability. The issue was linked to our Network provider, Cenic, which provided the following update:
START: 06:43 PDT, Thu 09/17/2026
END: 08:21 PDT, Thu 09/17/2026
SCOPE: Backbone Circuit Down
STATUS: Resolved
COMMENTS:
The outage between the backbone router and switch was resolved by resetting the optic for the affected link. Services have been restored, and no further impact is expected. This incident is considered resolved.
Investigating
Information Technology Services (ITS) experienced an issue with the network that impacted access to multiple systems. Our teams are investigating the cause of the issue and we will continue to monitor network stability.
Reported issue included but are not limited to: slowness with or failure to load Argos, Banner, DegreeWorks, OnBase; links missing from Splashboard, MyApps and myAccess; issues with remote access to RDP, email and Teams.
Issue Start Time: 9/17/26 7:51 am
Location: all campuses
Impact to Staff: May include Argos, Banner, DegreeWorks, MyApps and myAccess; slowness with remote access to RDP, Outlook, Teams.
Impact to Students: May include slowness or access to mySierra and DegreeWorks