All Staff,
The issue has been resolved. We will continue to monitor availability and stability of our systems.
Issue Start Time: 9/5/26 5:00 pm
Issue Resolution Time: 9/8/26 7:05 am
Location: all campuses
Impact to Staff: access to mySierra, Banner, Degree Works.
Impact to Students: access to mySierra, Banner, Degree Works.
Regards,
ITS Service Desk
Resolved
All Staff,
The issue has been resolved. We will continue to monitor availability and stability of our systems.
Issue Start Time: 9/5/26 5:00 pm
Issue Resolution Time: 9/8/26 7:05 am
Location: all campuses
Impact to Staff: access to mySierra, Banner, Degree Works.
Impact to Students: access to mySierra, Banner, Degree Works.
Regards,
ITS Service Desk
Investigating
All Staff,
On 9/7/26, Information Technology Services (ITS) discovered a certificate issue that impacts access to mySierra, Banner, and Degree Works where you may receive a 404 error page. There is no estimated time to resolve this issue, however we will provide periodic updates.
Issue Start Time: 9/5/26 5:00 pm
Location: all campuses
Impact to Staff: access to mySierra, Banner, Degree Works.
Impact to Students: access to mySierra, Banner, Degree Works.
Regards,
ITS Service Desk