Resolved
The application login issues have been resolved and the maintenance window has been completed. Users should now be able to login without issues.
Investigating
All Staff,
Information Technology Services (ITS) is currently investigating an issue affecting access to Degree Works. Users may receive a sign-in error when attempting to log in.
We are working to resolve the issue as quickly as possible and currently expect service to be restored by 7:00 a.m. on Friday, June 26, 2026.
We will provide additional updates as they become available.
Issue Start Time: 6/25/26 3:25 pm
Location: all campuses
Impact to Staff: access to Degree Works
Impact to Students: access to Degree Works